Facebooktwittergoogle_pluspinterestlinkedin

Are you a Firefox user?  If so, you’ll want to update to version 67.0.4 as soon as possible.  Just last week, Mozilla released Firefox 67.0.3 to address a critical remote code execution vulnerability that was being used in the wild to selectively target vulnerable systems.

Unfortunately, that proved to be just the tip of the iceberg.

Since then, the company discovered that the vulnerability they initially addressed was merely the second part in a chained pair of security flaws. The pair worked in tandem to drop and execute malicious code onto vulnerable systems.

In response, the company quickly released the latest version, 67.0.4, which addresses both links in the chain.  The issue, initially reported by Coinbase Security, is being tracked as CVE-2019-11708.

Its description reads as follows:

“Insufficient vetting of parameters passed with the Prompt: Open IPC message between child and parent processes can result in the non-sandboxed parent process opening web content chosen by a compromised child process.  When combined with additional vulnerabilities, this could result in executing arbitrary code on the user’s computer.”

Obviously, this is a serious issue indeed, especially since it’s one that’s already being actively exploited by hackers around the world.  If you’re not sure what version you’re running, open Firefox, go to the help menu, and click on “About Firefox.”  The software will take it from there and scan for a new version.  If one is available, it will let you know, and you can download and install it.

If you don’t want to go that route, just head to Mozilla’s website and grab the latest direct from there.

Kudos to the sharp-eyed researchers at Coinbase Security for spotting the issue, and to Mozilla for their rapid response.  Don’t take any chances.  Install the latest update today.

Used with permission from Article Aggregator

Facebooktwittergoogle_pluspinterestlinkedin